SYMPTOMS
1. The Bamboo Web License Manager shows this error:
"The exception thrown was An update conflict has occurred, and you must re-try this action"
2. During an installation, logs show an error like this:
An update conflict has occurred, and you must re-try this action. The object SPAdminFeature Name=Feature/a87f44e0-f218-47d7-968f-531755164ec6/720228ef-2ce5-447a-a0c0-f34140f325c8 was updated by DOMAIN\username, in the OWSTIMER (2948) process, on machine ServerName. View the tracing log for more information about the conflict.
CodePlex.SharePointInstaller.InstallException: An update conflict has occurred, and you must re-try this action.
3. System logs show errors like:
An update conflict has occurred, and you must re-try this action. The object UserProfileApplication Name=User Profile Service Application was updated by [User], in the OWSTIMER (3456) process, on machine [Server]
or
An unhandled exception occurred in the user interface.Exception Information: An update conflict has occurred, and you must re-try this action. The object SessionStateService Parent=SPFarm Name=SharePoint_Config is being updated by DOMAIN\username, in the w3wp process, on machine XXXXXX. View the tracing log for more information about the conflict
CAUSE
The error "An update conflict has occurred, and you must re-try this action" can occur "if the contents of the file system cache on the front-end servers are newer than the contents of the configuration database" - as stated by Microsoft in this support article: http://support.microsoft.com/kb/939308
Note: "After you perform a system recovery, you may have to manually clear the file system cache on the local server."
RESOLUTION
1. You can run a PowerShell script from Codeplex that will take care of this issue for you:
https://spcachecleaner.codeplex.com/
2. You can do these actions manually.
Follow the instructions posted by Microsoft here for SharePoint 2007:
http://support.microsoft.com/kb/939308 to fix your farm configuration before trying to activate the license again. (Steps are included further down on this page).
Also see these blogs:
SharePoint 2010 – Clearing the Configuration Cache
Clear the SharePoint Configuration Cache
Note: There is a difference in the location of the cache files on Windows Server 2008 versus Windows Server 2003.
In Windows Server 2008, the configuration cache is here:
In Windows Server 2008, the configuration cache is here:
Drive:\Documents and Settings\All Users\Application Data\Microsoft\SharePoint\Config\GUID
For more information about the "update conflict" error, see:
User Profile Service: An update conflict has occurred, and you must re-try this action
Central Admin: An update conflict has occurred, and you must re-try this action
Instructions for clearing the cache (from http://support.microsoft.com/kb/939308):
"To resolve this issue, clear the file system cache on all servers in the server farm on which the Windows SharePoint Services Timer service is running. To do this, follow these steps:
- Stop the Timer service. To do this, follow these steps:
- Click Start, point to Administrative Tools, and then click Services.
- Right-click Windows SharePoint Services Timer, and then click Stop.
- Close the Services console.
- On the computer that is running Microsoft Office SharePoint Server 2007 and on which the Central Administration site is hosted, click Start, click Run, type explorer, and then press ENTER.
- In Windows Explorer, locate and then double-click the following folder:
Drive:\Documents and Settings\All Users\Application Data\Microsoft\SharePoint\Config\GUID
-
- The Drive placeholder specifies the letter of the drive on which Windows is installed. By default, Windows is installed on drive C.
- The GUID placeholder specifies the GUID folder.
- The Application Data folder may be hidden. To view the hidden folder, follow these steps:
- On the Tools menu, click Folder Options.
- Click the View tab.
- In the Advanced settings list, click Show hidden files and folders under Hidden files and folders, and then click OK.
- In Windows Server 2008, the configuration cache is in the following location:
Drive:\ProgramData\Microsoft\SharePoint\Config\GUID
- Back up the Cache.ini file.
- Delete all the XML configuration files in the GUID folder. Do this so that you can verify that the GUID folder is replaced by new XML configuration files when the cache is rebuilt.
Note When you empty the configuration cache in the GUID folder, make sure that you do not delete the GUID folder and the Cache.ini file that is located in the GUID folder. - Double-click the Cache.ini file.
- On the Edit menu, click Select All.
- On the Edit menu, click Delete.
- Type 1, and then click Save on the File menu.
- On the File menu, click Exit.
- Start the Timer service. To do this, follow these steps:
- Click Start, point to Administrative Tools, and then click Services.
- Right-click Windows SharePoint Services Timer, and then click Start.
- Close the Services console.
- Make sure that the Cache.ini file in the GUID folder now contains its previous value. For example, make sure that the value of the Cache.ini file is not 1."
- Open Central Administration.
- In SP2007: Click the Operations tab, and then click Timer job status under Global Configuration. In SP2010: Go to Central Administration > Monitoring > Check Job status
- "In the list of timer jobs, verify that the status of the Config Refresh entry is Succeeded."
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